How Can We Help?

Eduroam Support for Older Devices

You are here:
< All Topics

Overview

A security change has been implemented on our wireless internet access that requires your devices to be updated to the latest version available to connect to Eduroam. If you need assistance, please visit SalukiTech with your device or chat with us salukitech.siu.edu

List of Supported Operating Systems

Android 5.0 and above

Win 7 and above (You may need to edit some settings for Windows 8, see here)

MacOS 10.13 and above (Link to Older Mac OS Versions) (What OS can my Mac Support?)

iOS 11 and above

iPadOS 13.1 and above

Technical Details:

The security protocols TLS 1.0 and TLS 1.1 have been deprecated (RFC 8996). The process began in 2018 and was finished in March 2021 (https://datatracker.ietf.org/doc/rfc8996/). These protocols are no longer safe to use due to multiple known security flaws.

As part of a recent update to the authentication servers for the “eduroam” wireless network, support for these protocols was removed. The only protocol currently supported is TLS 1.2. This should not be a problem for newer devices. However, some older devices that do not have support for TLS 1.2 could no longer be able to connect to the “eduroam” wireless network. If possible, the operating system on the device should be updated to a newer version that supports TLS 1.2.

Was this article helpful?
0 out Of 5 Stars
5 Stars 0%
4 Stars 0%
3 Stars 0%
2 Stars 0%
1 Stars 0%
How can we improve this article?
Please submit the reason for your vote so that we can improve the article.
Previous Connecting to SIU Limited a Smart Device or Game Console
Next Virtual Desktop Infrastructure (VDI) Guide

Leave a Reply

Table of Contents